Downtime - Meta Platform Connection Issues

Incident Report for Phyllo

Resolved

The issue affecting authentication and connection flows for Meta platforms (Instagram, IG Direct, and Facebook) has now been resolved.
Posted Jul 22, 2026 - 14:47 UTC

Investigating

We are currently investigating an issue affecting connections to Meta platforms (Instagram, IG Direct and Facebook). Due to an internal issue, new connection attempts may fail or be unable to complete successfully.

Our engineering team is actively working to identify the root cause and restore normal functionality as quickly as possible.

We apologise for the inconvenience and will provide further updates as soon as more information becomes available.
Posted Jul 21, 2026 - 18:27 UTC
This incident affected: Connect (Instagram, Facebook) and Engagement(Content) (Instagram, Facebook).